Re: [ACPI] [PATCH] Updated patches for PCI IRQ resource deallocationsupport [2/3]

From: Kenji Kaneshige
Date: Mon Sep 27 2004 - 00:48:40 EST


Zwane Mwaikambo wrote:
On Sat, 25 Sep 2004, Zwane Mwaikambo wrote:

Kenji Kaneshige wrote:

> - Changed acpi_pci_irq_disable() to leave 'dev->irq' as it
> is. Clearing 'dev->irq' by some magic constant
> (e.g. PCI_UNDEFINED_IRQ) is TBD.

This may not be safe with CONFIG_PCI_MSI, you may want to verify against that if you already haven't.


Thank you for commemts.
You are right. If the linux IRQ number is allocated by MSI code,
clearing 'dev->irq' would cause a problem. So we need to consider
clearing 'dev->irq' carefully.

The latest patch doesn't clear 'dev->irq' so far.

> +acpi_unregister_gsi (unsigned int irq)
> +{
> +}
> +EXPORT_SYMBOL(acpi_unregister_gsi);

Why not just make these static inlines in header files? Since you're on this, how about making irq_desc and friends dynamic too?

Sorry, i broke Cc.


I'm not quite sure what you are saying, but my idea is defining
acpi_unregister_gsi() as a opposite part of acpi_register_gsi().
Acpi_register_gsi() is defined for each arch (i386, ia64), so
acpi_unregister_gsi() is defined for each i386 and ia64 too.

Thanks,
Kenji Kaneshige

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/