Re: Add wait_event_timeout()

From: Russell King
Date: Sat Sep 25 2004 - 04:57:59 EST


On Sat, Sep 25, 2004 at 10:42:15AM +0100, Jon Masters wrote:
> On Sat, 25 Sep 2004 10:13:59 +0100, Russell King <rmk@xxxxxxxxxxxxxxxx> wrote:
>
> > There appears to be one case missing from the wait_event() family -
> > the uninterruptible timeout wait. The following patch adds this.
>
>
> Any reason it's called wait_event_timeout then rather than
> wait_event_uninterruptible_timeout?

Because I chose to follow the existing naming scheme.

wait_event() - uninterruptible wait
wait_event_interruptible() - interruptible wait
wait_event_interruptible_timeout() - interruptible wait with timeout

so, the uninterruptible wait with timeout can only logically be:

wait_event_timeout()

Lets not go starting a new naming scheme. 8)

--
Russell King
Linux kernel 2.6 ARM Linux - http://www.arm.linux.org.uk/
maintainer of: 2.6 PCMCIA - http://pcmcia.arm.linux.org.uk/
2.6 Serial core
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/