prio_tree generalization

From: Werner Almesberger
Date: Sun Jul 04 2004 - 20:26:02 EST


Hi Rajesh,

I'm currently experimenting with the prio_tree code in an elevator
("IO scheduler"), and I'm thinking about a way to avoid code
duplication.

The most straightforward approach seems to be to put everything
after prio_tree_init and before vma_prio_tree_add into a new file,
and #include that file. (And prio_tree_init should be shared.)

#including a .c file normally isn't exactly considered an epitome
of elegance, but in this case, there doesn't seem to be much of a
choice.

There's another issue: in the elevator, entries overlap only
rarely if at all, and it is sometimes useful to walk the tree in
sort order. As far as I can tell, RPSTs can be walked just like
RB trees if there are no overlaps on the path from the current to
the respective adjacent node.

Unfortunately, "prio_tree_next" is already taken. It would be nice
to follow the same naming scheme as RB trees, so perhaps
prio_tree_next could become prio_tree_more, or such ?

What do you think ?

- Werner

--
_________________________________________________________________________
/ Werner Almesberger, Buenos Aires, Argentina wa@xxxxxxxxxxxxxxx /
/_http://www.almesberger.net/____________________________________________/
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/