Re: ACPI suspend to RAM weirdness

From: Len Brown
Date: Thu Apr 22 2004 - 12:09:10 EST

On Thu, 2004-04-22 at 12:24, Jason Munro wrote:
> Hello all,
> I can sucessfully suspend with 'echo 3 > /proc/acpi/sleep' on my
> Toshiba
> Satellite 1410-S173. It also wakes up fine, except after waking it
> jumps to
> init 0 and shuts down. It's been this way with every kernel I have
> tried
> since 2.6.4. I know it worked with 2.6.1 but I'm not sure exactly at
> what
> point between that and 2.6.4 it changed, or even if this is a
> userspace or
> kernel issue. Yesterday I tried with 2.6.6-rc2 and rc2-mm1 and it
> still
> behaves the same.

We have some event/wakeup GPE weirdness lately.
You might try working around it by shutting down acpid
before you suspend -- it may be processing your wakeup
power button event as a signal to shut down.


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at