Problem with 2.6.3 and initrd

From: Derek Chen-Becker
Date: Thu Apr 22 2004 - 09:15:45 EST

I've been trying all day to get 2.6.3 booting on my server from 2.4.22. I've run into a major issue with the initrd, and I can't figure out what's going on. The kernel finds the initrd and mounts it on root, but then the first command I have (mount /proc) fails with an error that it can't create a lock on mtab because there is no space left on the device. Everything else after that blows up. I thought I'd be clever and create a bogus file on the initrd, then delete it as the first step in linuxrc so that there is space on the device, but I still get the same error. My 2.4.22 kernel works find with a very similar initrd, so I'm having trouble figuring out what is different here. I've done all kinds of google searches on this and haven't found anything very helpful other than some references to initramfs. Any thoughts?



| Derek Chen-Becker |
| derek@xxxxxxxxxxxxxxx |
| |
| |
| PGP key available on request or from public key servers |
| ID: 21A7FB53 |
| Fngrprnt: 209A 77CA A4F9 E716 E20C 6348 B657 77EC 21A7 FB53 |
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at