Re: 2.6.5-mm4 (hci_usb module unloading oops)

From: Martin Hermanowski
Date: Mon Apr 19 2004 - 15:33:24 EST

On Mon, Apr 12, 2004 at 03:03:53PM -0700, Greg KH wrote:
> On Mon, Apr 12, 2004 at 12:19:11PM +0200, Martin Hermanowski wrote:
> > I get an oops when I try to unload the hci_usb module.
> {sigh} I'm hating that driver right now...
> There are a number of pending bluetooth patches for that driver that fix
> a number of different bugs, so I'm leary of trying to see if this is a
> different one or not at this point in time. Care to apply all of the
> bluetooth patches and if this still happens, can you report it to the
> linux-usb-devel and bluez-devel mailing lists?

I can try these patches in the next days, can you point me to an url?

> > What other useful information can I provide?
> CONFIG_DEBUG_DRIVER might be good to set, and then we can see if we are
> not trying to remove the same device twice for some odd reason. If you
> do duplicate this, please include all of the debug log entries that
> happen from when you unplug the device.
> Also CONFIG_USB_DEBUG might help out.

I just tried 2.6.6-rc1-mm1 (patched with mppe and iscsi), same problem.

I compiled with CONFIG_DEBUG_DRIVER and CONFIG_USB_DEBUG, after booting,
I activate the usb-dongle (Fn+F5 on the IBM T41p), then I run `hciconfig
down' and `rmmod hci_usb', which triggers the problem

I uploaded both the config and the whole syslog file from the boot until
shutting down:

> > Apr 12 12:07:48 localhost udev[22216]: removing device node '/dev/hci0'
> Nice, glad to see udev is working for you :)

I'm using udev 0.024-2 from debian, and it is working quite well :-)

LLAP, Martin

Attachment: signature.asc
Description: Digital signature