Re: [PATCH] lockfs patch for 2.6

From: Chris Mason
Date: Fri Mar 12 2004 - 10:52:09 EST

On Fri, 2004-03-12 at 04:31, Christoph Hellwig wrote:

> Can we please rename write_super_lockfs to a sane name?
> freeze_fs/thaw_fs sounds like a good name.

> This looks ugly. What about returning the superblock from the freeze
> routine so you can simply pass it into the thaw routine?
I like it, will do.

> This looks grossly misnamed again. And why do you need to have
> sync_super_locks splitted out? Calling it on it's own doesn't make much
> sense.

Would you like this better:

device mapper code:
s = freeze_fs(bdev);
< create snap shot >
thaw_fs(bdev, s);

thaw_fs needs the bdev so it can up the bdev mount semaphore.


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at