Re: 2.6.4-mm1

From: Andi Kleen
Date: Thu Mar 11 2004 - 08:22:09 EST

Mickael Marchand <marchand@xxxxxxx> writes:

> [snip]
>> > while I am at it, I am running a 64 bits kernel with 32 bits debian
>> > testing and it seems some ioctl conversion fails
>> > that happened with all 2.6 I tried.
>> > here is the relevant kernel messages part :
>> > ioctl32(dmsetup:26199): Unknown cmd fd(3) cmd(c134fd00){01} arg(0804c0b0)
>> > on /dev/mapper/control
>> The device mapper version 1 ioctl interface was removed. Perhaps you need
>> to update your dm tools?
> the debian tools are built with ioctlv4 (and compat for v1)
> I also tried with my own compiled dm tools from source without success

If it just uses them for compatibility probes then the ioctl handler can
be silenced.

>> > ioctl32(fsck.reiserfs:201): Unknown cmd fd(4) cmd(80081272){00}
>> > arg(ffffdab8) on /dev/ide/host0/bus0/target0/lun0/part4
>> Is this something which 2.6 has always done, or is it new behaviour?
> always since 2.6 IIRC
>> reiserfs ioctl translation appears to be incomplete...
> ha :)

I will take a look at it.


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at