2.6.2: "filp->f_mode & 2..."

From: Ulrich Windl
Date: Thu Feb 12 2004 - 05:04:05 EST


Hi everybody!

I think there's one thing to change in kernel sources; consider this:
filp->f_mode & 2 || permission(filp->f_dentry->d_inode,2,NULL)

It's obvious to some, likely for others that "2" there really stands for
"002", the good old UNIX write permission. I'd suggest either to write
those permission bits in three-digit-octal, or introduce (maybe just use)
symbolic constants for improved readability.

One could even consider a macro MAY_WRITE(filp):
#define MAY_WRITE(filp) ((filp)->f_mode & WRITE_PERMISSION)
#define WRITE_PERMISSION 002

Regards,
Ulrich

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/