min_not_zero()

From: Matthew Wilcox
Date: Sat Sep 27 2003 - 20:58:08 EST



Here's a thought ...

#define min_not_zero(l, r) \
min((unsigned long)(l - 1), (unsigned long)(r - 1)) + 1

Seems to me that'll always give the right answer ... 0 if both 0,
otherwise the lower of the two. And it's kind of an awkward name.
How about making it *really* specific to request_queue, putting it in
blkdev.h and calling it request_sector_min() like so:

#define request_sector_min(a, b) \
min((a)->max_sectors - 1, (b)->max_sectors - 1) + 1

(no cast needed cos they're already unsigned. um, unless I've misremembered
how C constants work again... should they be 1U?)

--
"It's not Hollywood. War is real, war is primarily not about defeat or
victory, it is about death. I've seen thousands and thousands of dead bodies.
Do you think I want to have an academic debate on this subject?" -- Robert Fisk
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/