Re: virt_to_offset()

From: David Mosberger
Date: Mon Aug 11 2003 - 13:31:04 EST



Yoshifuji> In article <20030810013041.679ddc4c.davem@xxxxxxxxxx> (at
Yoshifuji> Sun, 10 Aug 2003 01:30:41 -0700), "David S. Miller"
Yoshifuji> <davem@xxxxxxxxxx> says:
>> > BTW, we spread ((long) ptr & ~PAGE_MASK); it seems ugly. > Why
>> don't we have vert_to_offset(ptr) or something like this? >
>> #define virt_to_offset(ptr) ((unsigned long) (ptr) & ~PAGE_MASK)
>> > Is this bad idea?

>> With some name like "virt_to_pageoff()" it sounds like a great
>> idea.

Yoshifuji> Okay. How about this? (I'm going to do the actual
Yoshifuji> conversion soon.)

It's a bad choice of name. X_to_Y() normally implies that X and Y are
basically different representations of the same thing (e.g., a page
pointer vs. a virtual address). However, virt_to_pageoff() is a
one-way translation, so it's misleading. In my opinion, it should be
called page_offset() or something like that.

--david
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/