Re: [PATCH] Washing suspend code

From: David Woodhouse (dwmw2@infradead.org)
Date: Sun Jul 20 2003 - 21:55:30 EST


On Wed, 2003-07-02 at 14:10, Dave Jones wrote:
> On Wed, Jul 02, 2003 at 10:43:11AM +0200, ffrederick@prov-liege.be wrote:
> > }
> > +int touchable_process (struct task_struct *p)
> > +{
> > + return(!((p->flags & PF_IOTHREAD) || (p == current) || (p->state == TASK_ZOMBIE)))
> > +
> > +}
>
> *horror*. Please keep the formatting of the original macro.
> It's a) more readable, and b) Documentation/CodingStyle compliant.

Bugger the formatting. The original macro invocation 'INTERESTING(p)'
may invoke 'continue;' and change the flow of execution in an utterly
unobvious manner. The 'if (something) continue;' form is _definitely_
better.

-- 
dwmw2

- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/



This archive was generated by hypermail 2b29 : Wed Jul 23 2003 - 22:00:42 EST