Re: [PATCH] Remove "cpu" arg to cpu_raise_softirq().

From: Linus Torvalds (torvalds@osdl.org)
Date: Wed Jul 02 2003 - 00:33:17 EST


On Tue, 1 Jul 2003, Rusty Russell wrote:
>
> I didn't change the name, but I dislike the layering:

Agreed. Change the name too, since you're changing the calling convention.

> Better would be:
> raise_softirq(int nr): completely general
> __raise_softirq(int nr): must have interrupts off
> __raise_softirq_noksoftirqd(int nr): doesn't wake ksoftirqd

Actually, why not just make the irq thing more explicit, and use the "__"
naming convention for the "internal use" version), ie more along the lines
of

        raise_softirq(int nr): completely general
        raise_softirq_irqoff(int nr): interrupts off
        __raise_softirq_irqoff(int nr): interrupts off, don't wake

instead..

                Linus

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/



This archive was generated by hypermail 2b29 : Mon Jul 07 2003 - 22:00:15 EST