AW: Problem unmounting initrd-romfs in 2.4.21

From: Tobias Reinhard (
Date: Fri Jun 20 2003 - 09:55:48 EST

>> I'm booting up with a initrd in a romfs. After loading all needed
>> modules and pivoting root I unmount the initrd and flush the used
>> buffers.
>> Since I updated to 2.4.21 I can't unmount the initrd - it says it's
>> busy, but it's no (or at least lsof does say so).
>> I use kernel 2.4.21 with /drivers/Makefile , /drivers/ide and
>> /include/linux/ide.h from ac1 to reenable ide-modules.
>> Anyone know the problem?
>Hm, just a guess: do you have devfs mounted to /dev
>on the initial ramdisk (probably automounted by the
>kernel, with config option CONFIG_DEVFS_MOUNT=y)?
Yes, I use DEVFS and this was my first thought too. But even if I
unmount /dev before pivoting it's busy. (btw. it worked that way up to

>Check the output of "mount", it'll show you if there's
>still something mounted under the "old" root.
After booting up completely I have the devfs at /dev where it should be
and the old root at /mnt. But it's still not umount-able. No other
mounts below it and no open files.

>We use initrd + devfs for ages now (we even use romfs for initrd like
you do), and it works fine with 2.4.21 too.

I just tried with 2.4.21-ac1 and it words perfectly. But I also want
grsecurity- and crypto-patch - so I can't use ac1... :-(

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

This archive was generated by hypermail 2b29 : Mon Jun 23 2003 - 22:00:32 EST