2.4.21 / IDE lost interrupt / ServerWorks problem

From: jfontain@free.fr
Date: Mon Jun 16 2003 - 06:31:15 EST

[Please CC me as I am not subscribed to the list]
I just upgraded from a 2.4.20 to 2.4.21 but had to revert due to the following
 hdd: dma_timer_expiry: dma status == 0x60
 hdd: timeout waiting for DMA
 hdd: lost interrupt
This chipset is:
  Bus 0, device 15, function 0:
    ISA bridge: ServerWorks CSB5 South Bridge (rev 147).
  Bus 0, device 15, function 1:
    IDE interface: ServerWorks CSB5 IDE Controller (rev 147).
  Bus 0, device 15, function 2:
    USB Controller: ServerWorks OSB4/CSB5 OHCI USB Controller (rev 5).
on a bi-pentium III machine.
With 2.4.20 and the ide1=ata66 kernel option, that setup worked great:
# /sbin/hdparm -t /dev/hdd
 Timing buffered disk reads: 64 MB in 1.37 seconds = 46.72 MB/sec
(thanks to all for such great performance (same as SCSI!))
For 2.4.21, I just added the new "Generic PCI IDE Chipset Support" (no help
provided), and recompiled, then rebooted. The 2.4.20 message:
  hdd:351651888sectors(180046 MB)w/2048KiBCache,CHS=21889/255/63,UDMA(100)
appeared on 2.4.21 as (notice that UDMA(100) has dissapeared):
  hdd:351651888sectors(180046 MB)w/2048KiBCache,CHS=21889/255/63
I then tried hdparm, which came up with only 2.5 MB/sec, then forced DMA which
hdparm, tested again and got the errors cited at the beginning of this
Please let me know if you'd like me to perform some tests, but as I can only
reboot once or twice at lunch time.
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

This archive was generated by hypermail 2b29 : Mon Jun 23 2003 - 22:00:18 EST