On Fri, May 16, 2003 at 03:36:24PM -0700, Greg KH wrote:
> On Thu, May 15, 2003 at 10:03:24PM +0200, Manuel Estrada Sainz wrote:
[snip]
> > Attached:
> > firmware.h
> > firmware_class.c:
> > The firmware support itself.
>
> Can you just send this as a patch to the current kernel next time? It's
> much easier to read and test with that way :)
When I updated my tree (via bk cvs gateway) to make the patch I noticed
some changes in sysfs's binary support.
In general, they look good, but the size of files is set in
sysfs_create_bin_file and not changeable later. This breaks
firmware_class.c :(
With current request_firmware(), the drivers don't tell the size of the
firmware, and in some cases they don't even know, so changing the
interface is no good.
I also don't understand why sysfs needs to keep a copy of the data in
it's own buffer. It has to ask the driver for any read/write anyway,
the previous approach of one page at a time looked better to me and
saves some kernel memory :-).
And the size checks could be skipped in case of zero size.
I'll include a change proposal to sysfs/bin.c next time.
Have a nice day
Manuel
-- --- Manuel Estrada Sainz <ranty@debian.org> <ranty@bigfoot.com> <ranty@users.sourceforge.net> ------------------------ <manuel.estrada@hispalinux.es> ------------------- Let us have the serenity to accept the things we cannot change, courage to change the things we can, and wisdom to know the difference. - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
This archive was generated by hypermail 2b29 : Fri May 23 2003 - 22:00:27 EST