Re: [PATCH] BUG(): sched.c: Line 944

From: Ingo Molnar (mingo@elte.hu)
Date: Tue Sep 17 2002 - 13:57:31 EST


On 17 Sep 2002, Robert Love wrote:

> OK so do we want to do (a):
>
> (moved down to after the preempt_disable() and release_kernel_lock())
>
> if (likely(current->state != TASK_ZOMBIE)
> if (unlikely((preempt_count() & ~PREEMPT_ACTIVE) != 1))
> ...
>
> or go with (b) where we split schedule() into schedule(),
> exit_schedule(), and do_schedule().

i'd do (a). current->state is to be used anyway, and the default-untaken
first branch should be cheap. Plus by moving things down the splitup of
the function would create more code duplication than necessery i think.

        Ingo

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/



This archive was generated by hypermail 2b29 : Mon Sep 23 2002 - 22:00:19 EST