check_dis(c|k)_change(|d): duplicated code

From: Yann Droneaud (yann.droneaud@iupmime.univ-lemans.fr)
Date: Sat Jan 27 2001 - 15:52:57 EST


I was looking up linux code to find why /proc/partitions report 'hdc' instead
of 'ide/host0/bus1/target0/lun0/cd'

example:
--------
major minor #blocks name

   8 0 1048575 scsi/host0/bus0/target6/lun0/disc
   3 0 3140928 ide/host0/bus0/target0/lun0/disc
   3 1 4000 ide/host0/bus0/target0/lun0/part1
   3 2 3132864 ide/host0/bus0/target0/lun0/part2
   3 64 3167640 ide/host0/bus0/target1/lun0/disc
   3 65 1 ide/host0/bus0/target1/lun0/part1
   3 67 899136 ide/host0/bus0/target1/lun0/part3
   3 68 165312 ide/host0/bus0/target1/lun0/part4
   3 69 1052289 ide/host0/bus0/target1/lun0/part5
   3 70 983776 ide/host0/bus0/target1/lun0/part6
   3 71 64480 ide/host0/bus0/target1/lun0/part7
  22 0 648180 hdc

I found a strange thing
     in 'fs/block_dev.c' there's a function 'check_disk_change'
 and in 'fs/devfs/base.c' there's a function 'check_disc_changed'
 They done exactly the same job. I think that one of these must be rewritted to
 call the other and it's not to me to tell you which one :-).

--
Yann Droneaud <yann.droneaud@iupmime.univ-lemans.fr>
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/



This archive was generated by hypermail 2b29 : Wed Jan 31 2001 - 21:00:28 EST