Re: [PATCH] bttv driver II

From: Gerd Knorr (kraxel@goldbach.in-berlin.de)
Date: Mon May 22 2000 - 14:15:56 EST


> - dep_tristate ' BT848 Video For Linux' CONFIG_VIDEO_BT848 $CONFIG_VIDEO_DEV $CONFIG_PCI $CONFIG_I2C_ALGOBIT
> + dep_tristate ' BT848 Video For Linux' CONFIG_VIDEO_BT848 $CONFIG_VIDEO_DEV $CONFIG_PCI $CONFIG_I2C_ALGOBIT $CONFIG_SOUND

Should'nt be needed.

> - btwrite(0xfffffUL, BT848_INT_STAT);
> + btwrite(~0x0UL, BT848_INT_STAT);

No, 0xfffff is correct.

> @@ -3505,7 +3515,6 @@
> astat=stat&btread(BT848_INT_MASK);
> if (!astat)
> return;
> - btwrite(astat,BT848_INT_STAT);
> @@ -3667,7 +3676,9 @@
> +
> + btwrite(astat,BT848_INT_STAT);
> +

Why this change?

> -int configure_bt848(struct pci_dev *dev, int bttv_num)
> +static void __init bttv_remove(struct pci_dev *pci_dev)
> +{
> + u8 command;
> + int j;
> + struct bttv *btv = pci_dev->driver_data;

Why do you move around the functions? Makes it harder to keep
track of the real changes :-(

          
> fail:
> - release_mem_region(pci_resource_start(btv->dev,0),
> + release_mem_region(btv->bt848_adr,
> pci_resource_len(btv->dev,0));

Why? The old code is easier to read.

> + return pci_module_init(&bttv_pci_driver);
> +module_init(bttv_init_module);
> +module_exit(bttv_cleanup_module);

Hmm, looks like I need a few more ifdef's for 2.2.x ....

How is the initialization order with the module_*() thing?
bttv needs a i2c initialized...

  Gerd

-- 
Protecting the children is a good way to get a lot of adults who cant
stand up for themselves.		-- seen in some sig on /.

- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.rutgers.edu Please read the FAQ at http://www.tux.org/lkml/



This archive was generated by hypermail 2b29 : Tue May 23 2000 - 21:00:22 EST