Re: [PATCH] HID: sensor-hub: Fix typo and improve documentation for sensor_hub_remove_callback()

From: David Lechner
Date: Wed Apr 30 2025 - 15:17:53 EST


On 4/30/25 1:23 PM, Chelsy Ratnawat wrote:
> Fixed a typo in "registered" and improved grammar for better readability
> and consistency with kernel-doc standards. No functional changes.
>
> Signed-off-by: Chelsy Ratnawat <chelsyratnawat2001@xxxxxxxxx>
> ---
> include/linux/hid-sensor-hub.h | 7 ++++---
> 1 file changed, 4 insertions(+), 3 deletions(-)
>
> diff --git a/include/linux/hid-sensor-hub.h b/include/linux/hid-sensor-hub.h
> index c27329e2a5ad..5d2ac79429d4 100644
> --- a/include/linux/hid-sensor-hub.h
> +++ b/include/linux/hid-sensor-hub.h
> @@ -130,10 +130,11 @@ int sensor_hub_register_callback(struct hid_sensor_hub_device *hsdev,
> /**
> * sensor_hub_remove_callback() - Remove client callbacks

This says "callbacks", so is it possible to have more than one registered at a
time?

> * @hsdev: Hub device instance.
> -* @usage_id: Usage id of the client (E.g. 0x200076 for Gyro).
> +* @usage_id: Usage id of the client (e.g. 0x200076 for Gyro).

should we also make gyro lower-case?

> *
> -* If there is a callback registred, this call will remove that
> -* callbacks, so that it will stop data and event notifications.
> +* Removes a previously registered callback for the given usage ID.
> +* Once removed, the client will no longer receive data or event
> +* notifications.

I like the revised wording, but possibly looses some clarity that could be
fixed with:

Removes a previously registered callback(s), if any, for the given usage ID.

As above, not sure if singular or plural callbacks is correct.

> */
> int sensor_hub_remove_callback(struct hid_sensor_hub_device *hsdev,
> u32 usage_id);