RE: [cocci] [PATCH v3 3/6] arm64: tlb: Convert the opencoded field modify

From: Keller, Jacob E
Date: Thu Apr 24 2025 - 11:24:28 EST




> -----Original Message-----
> From: cocci-request@xxxxxxxx <cocci-request@xxxxxxxx> On Behalf Of Jie Luo
> Sent: Wednesday, April 23, 2025 6:16 AM
> To: Russell King (Oracle) <linux@xxxxxxxxxxxxxxx>
> Cc: Yury Norov <yury.norov@xxxxxxxxx>; Rasmus Villemoes
> <linux@xxxxxxxxxxxxxxxxxx>; Julia Lawall <Julia.Lawall@xxxxxxxx>; Nicolas Palix
> <nicolas.palix@xxxxxxx>; Catalin Marinas <catalin.marinas@xxxxxxx>; Will
> Deacon <will@xxxxxxxxxx>; Marc Zyngier <maz@xxxxxxxxxx>; Oliver Upton
> <oliver.upton@xxxxxxxxx>; Joey Gouly <joey.gouly@xxxxxxx>; Suzuki K Poulose
> <suzuki.poulose@xxxxxxx>; Zenghui Yu <yuzenghui@xxxxxxxxxx>; linux-
> kernel@xxxxxxxxxxxxxxx; cocci@xxxxxxxx; linux-arm-kernel@xxxxxxxxxxxxxxxxxxx;
> kvmarm@xxxxxxxxxxxxxxx; andrew@xxxxxxx; quic_kkumarcs@xxxxxxxxxxx;
> quic_linchen@xxxxxxxxxxx; quic_leiwei@xxxxxxxxxxx;
> quic_suruchia@xxxxxxxxxxx; quic_pavir@xxxxxxxxxxx
> Subject: Re: [cocci] [PATCH v3 3/6] arm64: tlb: Convert the opencoded field
> modify
>
>
>
> On 4/18/2025 2:11 AM, Russell King (Oracle) wrote:
> > On Thu, Apr 17, 2025 at 06:47:10PM +0800, Luo Jie wrote:
> >> Replaced below code with the wrapper FIELD_MODIFY(MASK, &reg, val)
> >> - reg &= ~MASK;
> >> - reg |= FIELD_PREP(MASK, val);
> >> The semantic patch that makes this change is available
> >> in scripts/coccinelle/misc/field_modify.cocci.
> >>
> >> More information about semantic patching is available at
> >> https://coccinelle.gitlabpages.inria.fr/website
> >>
> >> Signed-off-by: Luo Jie <quic_luoj@xxxxxxxxxxx>
> >> ---
> >> arch/arm64/include/asm/tlbflush.h | 3 +--
> >> 1 file changed, 1 insertion(+), 2 deletions(-)
> >>
> >> diff --git a/arch/arm64/include/asm/tlbflush.h
> b/arch/arm64/include/asm/tlbflush.h
> >> index eba1a98657f1..0d250ef4161c 100644
> >> --- a/arch/arm64/include/asm/tlbflush.h
> >> +++ b/arch/arm64/include/asm/tlbflush.h
> >> @@ -112,8 +112,7 @@ static inline unsigned long get_trans_granule(void)
> >> level >= 0 && level <= 3) { \
> >> u64 ttl = level & 3; \
> >> ttl |= get_trans_granule() << 2; \
> >> - arg &= ~TLBI_TTL_MASK; \
> >> - arg |= FIELD_PREP(TLBI_TTL_MASK, ttl); \
> >> + FIELD_MODIFY(TLBI_TTL_MASK, &arg, ttl); \
> >
> > This could equally be:
> > arg = u64_replace_bits(arg, ttl, TLBI_TTL_MASK);
> >
> > which already exists, so doesn't require a new macro to be introduced.
> >
> Looks like the new macro FIELD_MODIFY() is accepted by Yury, maybe we
> can keep to use FIELD_MODIFY() with this change for better readability?

I'd prefer this version too rather than a pointer that modifies in place. Feels like it fits better with the other FIELD macros which don't take pointers and return their bits by value.