Re: [PATCH 1/4] i2c: designware: Create shared header hosting driver name

From: Florian Fainelli
Date: Tue Apr 23 2024 - 21:22:30 EST




On 4/23/2024 4:59 PM, Andy Shevchenko wrote:
Tue, Apr 23, 2024 at 04:36:19PM -0700, Florian Fainelli kirjoitti:
We have a number of drivers that reference the string "i2c_designware"
yet this is copied all over the places with opportunities for this
string being mis-used. Create a shared header that defines this as a
constant that other drivers can reference.

...

#include <linux/i2c.h>
+#include <linux/i2c-designware.h>

Can it be hidden in the subfolder?

That would require the MFD and ethernet drivers to include relative to where they are in the source tree, do we really want that?


...

-#define DRIVER_NAME "i2c-designware-pci"
+#define DRIVER_NAME I2C_DESIGNWARE_NAME "-pci"

Oh, this makes all the things hard to read.

OK, besides there is a change for '_' when it was a '-' before, so maybe I should drop that hunk.


/* Work with hotplug and coldplug */
-MODULE_ALIAS("i2c_designware-pci");
+MODULE_ALIAS(DRIVER_NAME);

I believe we shouldn't use MODULE_ALIAS() without real justification.

Pre-existing change.
--
Florian

Attachment: smime.p7s
Description: S/MIME Cryptographic Signature