Re: [PATCH 7/7] cpuidle/poll_state: replace cpu_relax with smp_cond_load_relaxed

From: Will Deacon
Date: Mon Jan 29 2024 - 13:16:21 EST


On Sun, Jan 28, 2024 at 11:22:50PM +0200, Mihai Carabas wrote:
> La 11.12.2023 13:46, Will Deacon a scris:
> > On Mon, Nov 20, 2023 at 04:01:38PM +0200, Mihai Carabas wrote:
> > > cpu_relax on ARM64 does a simple "yield". Thus we replace it with
> > > smp_cond_load_relaxed which basically does a "wfe".
> > >
> > > Suggested-by: Peter Zijlstra <peterz@xxxxxxxxxxxxx>
> > > Signed-off-by: Mihai Carabas <mihai.carabas@xxxxxxxxxx>
> > > ---
> > > drivers/cpuidle/poll_state.c | 14 +++++++++-----
> > > 1 file changed, 9 insertions(+), 5 deletions(-)
> > >
> > > diff --git a/drivers/cpuidle/poll_state.c b/drivers/cpuidle/poll_state.c
> > > index 9b6d90a72601..440cd713e39a 100644
> > > --- a/drivers/cpuidle/poll_state.c
> > > +++ b/drivers/cpuidle/poll_state.c
> > > @@ -26,12 +26,16 @@ static int __cpuidle poll_idle(struct cpuidle_device *dev,
> > > limit = cpuidle_poll_time(drv, dev);
> > > - while (!need_resched()) {
> > > - cpu_relax();
> > > - if (loop_count++ < POLL_IDLE_RELAX_COUNT)
> > > - continue;
> > > -
> > > + for (;;) {
> > > loop_count = 0;
> > > +
> > > + smp_cond_load_relaxed(&current_thread_info()->flags,
> > > + (VAL & _TIF_NEED_RESCHED) ||
> > > + (loop_count++ >= POLL_IDLE_RELAX_COUNT));
> > > +
> > > + if (loop_count < POLL_IDLE_RELAX_COUNT)
> > > + break;
> > > +
> > > if (local_clock_noinstr() - time_start > limit) {
> > > dev->poll_time_limit = true;
> > > break;
> > Doesn't this make ARCH_HAS_CPU_RELAX a complete misnomer?
>
> This controls the build of poll_state.c and the generic definition of
> smp_cond_load_relaxed (used by x86) is using cpu_relax(). Do you propose
> other approach here?

Give it a better name? Having ARCH_HAS_CPU_RELAX control a piece of code
that doesn't use cpu_relax() doesn't make sense to me.

Will