Re: [PATCH] x86/mm/cpa: Warn if set_memory_XXcrypted() fails

From: Tom Lendacky
Date: Thu Oct 26 2023 - 09:37:47 EST


On 10/25/23 21:04, Edgecombe, Rick P wrote:
On Wed, 2023-10-25 at 11:10 -0700, Kuppuswamy Sathyanarayanan wrote:
Looks good to me.

Reviewed-by: Kuppuswamy Sathyanarayanan
<sathyanarayanan.kuppuswamy@xxxxxxxxxxxxxxx>


Thanks!


IMO, you can avoid "out" label with (!ret && !x86_platform....)
check. But it is upto
you.

Hmm, yes it could. I think it's a little easier to read as is, but just
my opinion as well.

It might be even easier to read to just have:

if (ret)
return ret;

if (!x86_platform...)
goto vmm_fail

return 0;

since jumping to the out: label just does a return anyway.

Thanks,
Tom