Re: [PATCH] ACPI: Rename acpi_scan_device_not_present() to be about enumeration

From: Miguel Luis
Date: Tue Oct 24 2023 - 06:15:50 EST


Hi Russell,

> On 20 Oct 2023, at 18:47, Russell King <rmk+kernel@xxxxxxxxxxxxxxx> wrote:
>
> From: James Morse <james.morse@xxxxxxx>
>
> acpi_scan_device_not_present() is called when a device in the
> hierarchy is not available for enumeration. Historically enumeration
> was only based on whether the device was present.
>
> To add support for only enumerating devices that are both present
> and enabled, this helper should be renamed. It was only ever about
> enumeration, rename it acpi_scan_device_not_enumerated().
>
> No change in behaviour is intended.
>
> Signed-off-by: James Morse <james.morse@xxxxxxx>
> Reviewed-by: Gavin Shan <gshan@xxxxxxxxxx>
> Signed-off-by: Russell King (Oracle) <rmk+kernel@xxxxxxxxxxxxxxx>

Fixes: 443fc8202272 ("ACPI / hotplug: Rework generic code to handle suprise removals”) ?

> ---
> This is another patch from James' aarch64 hotplug vcpu series.
>
> I asked:
>> Is this another patch which ought to be submitted without waiting
>> for the rest of the series?
> to which Jonathan Cameron replied:
>> Looks like a valid standalone change to me.
>
> So let's get this queued up.
>
> drivers/acpi/scan.c | 8 ++++----
> 1 file changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/acpi/scan.c b/drivers/acpi/scan.c
> index ed01e19514ef..17ab875a7d4e 100644
> --- a/drivers/acpi/scan.c
> +++ b/drivers/acpi/scan.c
> @@ -289,10 +289,10 @@ static int acpi_scan_hot_remove(struct acpi_device *device)
> return 0;
> }
>
> -static int acpi_scan_device_not_present(struct acpi_device *adev)
> +static int acpi_scan_device_not_enumerated(struct acpi_device *adev)
> {
> if (!acpi_device_enumerated(adev)) {
> - dev_warn(&adev->dev, "Still not present\n");
> + dev_warn(&adev->dev, "Still not enumerated\n");
> return -EALREADY;
> }
> acpi_bus_trim(adev);
> @@ -327,7 +327,7 @@ static int acpi_scan_device_check(struct acpi_device *adev)
> error = -ENODEV;
> }
> } else {
> - error = acpi_scan_device_not_present(adev);
> + error = acpi_scan_device_not_enumerated(adev);
> }
> return error;
> }
> @@ -339,7 +339,7 @@ static int acpi_scan_bus_check(struct acpi_device *adev, void *not_used)
>
> acpi_bus_get_status(adev);
> if (!acpi_device_is_present(adev)) {
> - acpi_scan_device_not_present(adev);
> + acpi_scan_device_not_enumerated(adev);

Feel free to add

Reviewed-by: Miguel Luis <miguel.luis@xxxxxxxxxx>

Thank you

Miguel

> return 0;
> }
> if (handler && handler->hotplug.scan_dependent)
> --
> 2.30.2
>
>