Re: [PATCH v3]vt: use vc_allocate in con_init

From: Jiri Slaby
Date: Mon Jan 06 2014 - 03:56:18 EST


On 01/02/2014 08:48 AM, Wang YanQing wrote:
> After a5f4f52e82114e85aa1a066bd1a450acc19a464d
> ("vt: use kzalloc() instead of the bootmem allocator"),
> con_init began to use kzalloc to initialize vc_data,
> this patch convert con_init to use vc_allocate.
>
> The benefit we get:
> 1: reduce code duplication
> 2: vc_allocate is more robust
> 3: use kmalloc instead of kzalloc for vc_screenbuf
>
> Signed-off-by: Wang YanQing <udknight@xxxxxxxxx>
> ---
> Changes v2-v3:
> 1: fix warnings reported by checkpatch.pl
> 2: clarify changelog
>
> drivers/tty/vt/vt.c | 28 ++++++++++++++--------------
> drivers/tty/vt/vt_ioctl.c | 8 ++++----
> include/linux/vt_kern.h | 2 +-
> 3 files changed, 19 insertions(+), 19 deletions(-)
>
> diff --git a/drivers/tty/vt/vt.c b/drivers/tty/vt/vt.c
> index 15aaa01..720a8f9 100644
> --- a/drivers/tty/vt/vt.c
> +++ b/drivers/tty/vt/vt.c
> @@ -748,7 +748,8 @@ static void visual_init(struct vc_data *vc, int num, int init)
> vc->vc_screenbuf_size = vc->vc_rows * vc->vc_size_row;
> }
>
> -int vc_allocate(unsigned int currcons) /* return 0 on success */
> +/* return 0 on success */
> +int vc_allocate(unsigned int currcons, int early)

Could you use
bool/true/false
instead of
int/1/0
please?

--
js
suse labs
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/