Re: Kconfig "softdepends" idea

From: Sam Ravnborg
Date: Tue Apr 30 2013 - 06:24:51 EST


>
> So, my idea is to have a new kind of Kconfig dependency. I'll call it
> "softdepends" in lack of better name. A driver maintainer could use
> "softdepends on ARCH_OMAP", instead of "depends on ARCH_OMAP", to say
> that this driver does not actually build depend on ARCH_OMAP, but for
> all normal purposes it does.
>
> Normally, this would result in the same behavior as the normal
> "depends", and Linus would not get a questions whether he wants to
> enable this OMAP specific driver or not, and the driver would not be
> visible on the menuconfig.
>
> But the user could enable the driver if he explicitly so wants. Perhaps
> a Kconfig option such as "ignore softdepends", enabling of which would
> allow the user to enable the drivers that use softdepends. Or, maybe
> just require the user to add the config option manually into his .config.

If I understand you correct this is already possible today without
extending the kconfig language.

config OMAP_SPECIFIC_DRIVER
depends on ARCH_OMAP || SHOW_ALL_DRIVERS


If SHOW_ALL_DRIVERS are "y" then user can say "y" to the OMAP specific driver too,
even without ARCH_OMAP being selected.

Sam
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/