Re: [PATCH 08/10] x86, xen, mm: fix mapping_pagetable_reserve logic

From: H. Peter Anvin
Date: Tue Oct 09 2012 - 02:12:40 EST


On 10/09/2012 12:39 PM, Yinghai Lu wrote:
> */
> struct x86_init_mapping {
> - void (*pagetable_reserve)(u64 start, u64 end);
> + void (*make_range_readwrite)(u64 start, u64 end);
> };
>

Here you go from one misleading name to another. Another classic case
of "why hooks suck."

make_range_readwrite is particularly toxic, though, because it makes it
sound like it something along the lines of set_memory_rw(), which it
most distinctly is not.

Furthermore, the naming makes me really puzzled why it is there at all.
It makes me suspect, but because the patchset is so messy, it is hard
for me to immediately prove, that you're still missing something important.

However, for example:

> unsigned long __initdata pgt_buf_start;
> unsigned long __meminitdata pgt_buf_end;
> unsigned long __meminitdata pgt_buf_top;
> +unsigned long __initdata early_pgt_buf_start;
> +unsigned long __meminitdata early_pgt_buf_end;
> +unsigned long __meminitdata early_pgt_buf_top;
>
> bool __init is_pfn_in_early_pgt_buf(unsigned long pfn)
> {
> - return pfn >= pgt_buf_start && pfn < pgt_buf_top;
> + return (pfn >= early_pgt_buf_start && pfn < early_pgt_buf_top) ||
> + (pfn >= pgt_buf_start && pfn < pgt_buf_top);
> }

Magic variables augmented with more magic variables. Why? This also
seems to assume that we still do all the kernel page tables in one
chunk, which is exactly what we don't want to do.

-hpa

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/