Re: [PATCH 3/4] kbuild: link of vmlinux moved to a script

From: Sam Ravnborg
Date: Sat May 05 2012 - 04:29:27 EST


On Sat, May 05, 2012 at 01:05:15AM +0200, Michal Marek wrote:
> Hi Sam,
>
> Thanks a lot for this work and sorry for the delay.
>
> Dne 28.4.2012 22:59, Sam Ravnborg napsal(a):
> > +kallsymso=""
> > +kallsyms_vmlinux=""
> > +if [ -n "${CONFIG_KALLSYMS}" ]; then
> > +
> [...]
> > +
> > + kallsymso=.tmp_kallsyms2.o
> > + kallsyms_vmlinux=.tmp_vmlinux2
> > +
> > + # step 1
> > + vmlinux_link "" .tmp_vmlinux1
> > + kallsyms .tmp_vmlinux1 .tmp_kallsyms1.o
> > +
> > + # step 2
> > + vmlinux_link .tmp_kallsyms1.o .tmp_vmlinux2
> > + kallsyms .tmp_vmlinux2 .tmp_kallsyms2.o
> > +
> > + # step 2a
> > + if [ -n "${KALLSYMS_EXTRA_PASS}" ]; then
> > + kallsymso=.tmp_kallsyms3.o
> > + kallsyms_vmlinux=.tmp_vmlinux2
>
> This should read ".tmp_vmlinux3".
Well spotted!

> Also, how about storing these two
> variables in the kallsyms() function instead? That way, you have the
> assignment in one place only and this block becomes a little simpler.
I kep them as is - as the current version is more explicit.
Hiding this inside kallsyms() is fewer lines but less obvious.

And part of this was to increase readability.

Updated patch-set sent out.

Thanks,
Sam
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/