[Patch v2] btrfs: use file_remove_suid() after i_mutex is held

From: Amerigo Wang
Date: Mon Jul 06 2009 - 03:19:20 EST



V1 -> V2:
Move kmalloc() before mutex_lock(), suggested by Arjan.

file_remove_suid() should be called with i_mutex held,
file_update_time() too. So move them after mutex_lock().

Plus, check the return value of kmalloc().

Signed-off-by: WANG Cong <amwang@xxxxxxxxxx>
Cc: Arjan <arjan@xxxxxxxxxxxxx>
Cc: Chris Mason <chris.mason@xxxxxxxxxx>
Cc: Yan Zheng <zheng.yan@xxxxxxxxxx>
Cc: Sven Wegener <sven.wegener@xxxxxxxxxxx>
Cc: Josef Bacik <jbacik@xxxxxxxxxx>
Cc: Jeff Mahoney <jeffm@xxxxxxxx>

---
diff --git a/fs/btrfs/file.c b/fs/btrfs/file.c
index 7c3cd24..09ef5d6 100644
--- a/fs/btrfs/file.c
+++ b/fs/btrfs/file.c
@@ -944,14 +944,17 @@ static ssize_t btrfs_file_write(struct file *file, const char __user *buf,
if (count == 0)
goto out_nolock;

+ pages = kmalloc(nrptrs * sizeof(struct page *), GFP_KERNEL);
+ if (!pages)
+ goto out_nolock;
+
+ mutex_lock(&inode->i_mutex);
+
err = file_remove_suid(file);
if (err)
- goto out_nolock;
+ goto out;
file_update_time(file);

- pages = kmalloc(nrptrs * sizeof(struct page *), GFP_KERNEL);
-
- mutex_lock(&inode->i_mutex);
BTRFS_I(inode)->sequence++;
first_index = pos >> PAGE_CACHE_SHIFT;
last_index = (pos + count) >> PAGE_CACHE_SHIFT;
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/