Re: [TOMOYO #14 (mmotm 2008-12-30-16-05) 02/10] Singly linked list implementation.

From: Tetsuo Handa
Date: Thu Jan 08 2009 - 01:20:36 EST


Serge E. Hallyn wrote:
> > TOMOYO's singly linked list (which is named as "list1") implementation has
> > below characteristics.
> >
> > (1) Supports "add" and "read" operations.
> > (2) Caller holds a lock when adding, but doesn't hold a lock when reading.
> > (3) Iteration method (for_each_*) needs to call rcu_dereference() because
> > caller doesn't hold a lock when reading.
> >
> > I think it is not a good thing to rename "list1" to "slist".
>
> How about alist (or aolist) for append-only list?
>
> The problem with list1 is that it *really* doesn't imply the
> characteristics you cite.
>
OK.

A developer who reads a code using this list likely wonders
"Why no read_lock() before reading this list?".
Thus, I'd like to rename to "rlfl" (Read-Lock-Free List).
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/