Re: [patch 0/7] Add IRQF_IRQPOLL_IRQ flag to allow irqpoll
From: Guennadi Liakhovetski
Date: Tue Mar 27 2007 - 01:02:07 EST
On Sun, 25 Mar 2007, Bernhard Walle wrote:
> * Guennadi Liakhovetski <g.liakhovetski@xxxxxx> [2007-03-24 00:21]:
> > On Fri, 23 Mar 2007, Bernhard Walle wrote:
> > > * Guennadi Liakhovetski <g.liakhovetski@xxxxxx> [2007-03-23 23:15]:
> > > > On Fri, 23 Mar 2007, Bernhard Walle wrote:
> > > >
> > > > > irqpoll is broken on some architectures that don't use the IRQ 0 for the timer
> > > > > interrupt like IA64. This patch adds a IRQF_IRQPOLL_IRQ flag.
> > > >
> > > > emn, please, cannot we come up with a better name - one that doesn't have
> > > > "IRQ" 3 (!) times in it?...
> > >
> > > Well, it was suggested by Andrew. What's your suggestion?
> > Purely esthetically (ehm, am I saying that?...) your original suggestion
> > to use IRQF_IRQPOLL looks better to me. Or even IRQF_POLL, but, maybe,
> > it's a bit too much of a simplification.
> I personally don't care very much about the naming. So I think it's
> Andrews final decision ...
Sure. And for him to have a better chance to do this, I'll fix his email
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/