On Thu, Jun 26, 2003 at 12:35:25AM +0100, Matthew Wilcox wrote:
> I'd kind of like to get rid of pci_dev->slot_name. It's redundant with
> pci_dev->dev.bus_id, but that's one hell of a search and replace job.
> So let me propose pci_name(pci_dev) as a replacement. That has the
> benefit of being shorter than either of the others and lets us do fun
> & interesting things later (maybe construct it on the fly for systems
> that want to save 20 bytes per device?). We can transition it in over
> 2.5/2.6/2.7 and kill pci_dev->slot_name for 2.8.
That sounds reasonable. But do we really need to do this for 2.6?
Just trying to keep things sane...
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to firstname.lastname@example.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
This archive was generated by hypermail 2b29 : Mon Jun 30 2003 - 22:00:22 EST